ATENÇÃO NOVOS USUÁRIOS

Se registrou recentemente? Seu cadastro será avaliado e mendiante aprovação, a conta será ativada e você poderá usufruir do fórum. O tempo de avaliação gira em torno de 24 a 48 horas.

Esqueceu sua senha?

Você pode usar o mecanismo de lembrete neste link: Recuperar senha

Você receberá um link de reativação no email cadastrado.

Não recebeu o email? Lembre-se checar o Lixo Eletrônico.

Calculo de data/hora com critérios

Dúvidas gerais sobre Excel
Marciel Silva
Colaborador
Colaborador
Mensagens: 98
Registrado em: Qui Nov 01, 2012 2:37 pm

Calculo de data/hora com critérios

Mensagem por Marciel Silva » Sex Ago 29, 2014 2:09 pm

Prezados, boa tarde!

Seguinte:

em A1 tenho a data: 27/08/2014 - em B1 tenho a hora: 10:30:00 (data e hora de inicio)
em C1 tenho a data: 28/08/2014 - em d1 tenho a hora: 15:00:00 (data e hora do término)
O Critério é calcular sobre: das 07:00 ás 12:00 e das 13:00 ás 17:00 (horas trabalhas no dia)

Assim, o resultado seria: no dia 27/08 total de 5 horas e 30 minutos e no dia 28/08 de 7 horas.
Preciso que na célula E1 me dê o total que seria a soma das 5:30 + 7 = 12 horas e 30 minutos.

Desde já agradeço!


Marciel Silva
Se suas dúvidas foram esclarecidas, marque o tópico como [RESOLVIDO].
E agradeça aqueles que voluntariamente pôde te auxiliar clicando no joinha.
m-m@r7.com

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Avatar do usuário
Reinaldo
Jedi
Jedi
Mensagens: 1422
Registrado em: Sex Ago 01, 2014 4:09 pm
Localização: Garça - SP / SCS - SP

Re: Calculo de data/hora com critérios

Mensagem por Reinaldo » Sex Ago 29, 2014 4:31 pm

Sem grande analise, mas creio que seria algo próximo ao modelo anexo
Anexos
tempo_Total.zip
(14.91 KiB) Baixado 131 vezes


Reinaldo
:oops: :D :mrgreen: :geek:

Marciel Silva
Colaborador
Colaborador
Mensagens: 98
Registrado em: Qui Nov 01, 2012 2:37 pm

Re: Calculo de data/hora com critérios

Mensagem por Marciel Silva » Sex Ago 29, 2014 10:48 pm

Reinaldo, boa noite!

Muito obrigado pela atenção!

Realmente é isso mesmo que eu preciso. Porém, quando eu coloco as duas datas iguais, a soma das horas não batem.
Como posso resolver isso?

Desde já agradeço novamente.

Att,


Marciel Silva
Se suas dúvidas foram esclarecidas, marque o tópico como [RESOLVIDO].
E agradeça aqueles que voluntariamente pôde te auxiliar clicando no joinha.
m-m@r7.com

Avatar do usuário
Reinaldo
Jedi
Jedi
Mensagens: 1422
Registrado em: Sex Ago 01, 2014 4:09 pm
Localização: Garça - SP / SCS - SP

Re: Calculo de data/hora com critérios

Mensagem por Reinaldo » Sáb Ago 30, 2014 10:58 am

Experimente assim:
no exemplo enviado em E7=SE(I2>I1;F2-J1-E3+J2-D2-E3;SE(E(I2=I1;J2<F2;J2>E2);J2-J1-E3))


Reinaldo
:oops: :D :mrgreen: :geek:

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Marciel Silva
Colaborador
Colaborador
Mensagens: 98
Registrado em: Qui Nov 01, 2012 2:37 pm

Re: Calculo de data/hora com critérios

Mensagem por Marciel Silva » Dom Ago 31, 2014 12:10 am

Reinaldo,

Perfeito... Exatamente isto!

Muito obrigado pela ajuda!

Bom domingo.

Att,


Marciel Silva
Se suas dúvidas foram esclarecidas, marque o tópico como [RESOLVIDO].
E agradeça aqueles que voluntariamente pôde te auxiliar clicando no joinha.
m-m@r7.com

Marciel Silva
Colaborador
Colaborador
Mensagens: 98
Registrado em: Qui Nov 01, 2012 2:37 pm

Re: Calculo de data/hora com critérios

Mensagem por Marciel Silva » Sex Set 19, 2014 3:27 pm

Reinaldo, boa tarde!

Como não tem a opção de colocar como resolvido o tópico, resolvi usar o mesmo para pedir mais uma vez a sua ajuda sobre o mesmo assunto.

A fórmula neste tópico que você montou para mim funcionou beleza.
O problema que está acontecendo é que se eu colocar um intervalo maior, ele soma até 17:38:00.

Exemplo: 15/09/2014 07:20:00 até 30/09/2014 16:48:00 - daria umas 105 horas.

Só que ele para no 17:38:00

Como faço para resolver essa questão?

Desde já agradeço.


Marciel Silva
Se suas dúvidas foram esclarecidas, marque o tópico como [RESOLVIDO].
E agradeça aqueles que voluntariamente pôde te auxiliar clicando no joinha.
m-m@r7.com

Avatar do usuário
Reinaldo
Jedi
Jedi
Mensagens: 1422
Registrado em: Sex Ago 01, 2014 4:09 pm
Localização: Garça - SP / SCS - SP

Re: Calculo de data/hora com critérios

Mensagem por Reinaldo » Seg Set 22, 2014 9:03 am

Talvez assim
E7=SE(I2>I1;(((I2-1)-I1)*(F2-D2-E3))+F2-J1-E3+J2-D2-E3;SE(E(I2=I1;J2<F2;J2>E2);J2-J1-E3))


Reinaldo
:oops: :D :mrgreen: :geek:

Marciel Silva
Colaborador
Colaborador
Mensagens: 98
Registrado em: Qui Nov 01, 2012 2:37 pm

Re: Calculo de data/hora com critérios

Mensagem por Marciel Silva » Ter Set 23, 2014 11:26 am

Reinaldo,

Mais uma vez muito obrigado.

Resolveu meu problema!

Agradeço!


Marciel Silva
Se suas dúvidas foram esclarecidas, marque o tópico como [RESOLVIDO].
E agradeça aqueles que voluntariamente pôde te auxiliar clicando no joinha.
m-m@r7.com

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Responder