Tag Archives: Curinga

Excel – Os segredos da Função CONT.SE

A função CONT.SE é uma velha conhecido do Excel, até para os não muito veteranos. Em resumo, ela conta a ocorrência de um determinado critério ou valor em um Range de células, na seguinte sintaxe:

CONT.SE(intervalo;critério)

Num exemplo simples, em uma lista em que temos a lista:

A B
1 Preço Está?
2 1,00 Baixo
3 2,00 Baixo
4 5,00 Médio
5 7,00 Alto
6 10,00 Alto

A fórmula CONT.SE(B2:B6;”Alto”) nos diria quantos preços estão “Altos” nessa lista, ou seja, 2.

Muito útil. O Excel 2007 ainda trouxe o CONT.SES, que incrementa a função, tornando possível utilizar mais de um critério na contagem, eliminando uma série de problemáticas que tínhamos só com o CONT.SE. Melhor ainda!

Mas, há um pequeno segredo no parâmetro critério que pode ser usado para tornar a função mais poderosa. Por exemplo, imagine a lista abaixo:

A B
1 Cliente Está?
2 A Satisfeito
3 B Muito Satisfeito
4 C Insatisfeito
5 D Satisfeito
6 E Insatisfeito
7 F Muito Insatisfeito

É um exemplo simples, como o primeiro, em uma grande quantidade de dados, pode ajudar muito. Vamos a algumas contagens. De pronto, seria fácil contar exatamente os itens:

  • Satisfeito
  • Muito Satisfeito
  • Insatisfeito
  • Muito Insatisfeito

Mas, se quiséssemos contar, por exemplo, todos os níveis de insatisfação. Para isso, seria preciso contar tantos os Insatisfeitos, como os Muito Insatisfeitos. Neste caso, entra o truque dos caracteres curinga que já foi comentado em outro post neste blog:

https://www.tomasvasquez.com.br/blog/microsoft-office/excel-extendendo-o-filtro-avancado-usando-curingas

Vamos ao exemplo. Quero através do CONT.SE, saber quantos clientes insatisfeitos tenho na lista, independente se muito, pouco, etc. A seguinte fórmula:

=CONT.SE(B2:B7;”Insatisfeito”)

Me retorna o número 2, que não é o que desejamos. Resolvemos o problema com o curinga *, fazendo a fórmula ficar assim:

=CONT.SE(B2:B7;”*Insatisfeito”)

Note o * antes da palavra “Insatisfeito”. É ele quem resolve o problema. Se quiséssemos a mesma coisa, mas para a palavra “Muito”, seria algo assim:

=CONT.SE(B2:B7;”Muito*”)

Neste caso, o * ficou no final, pois queremos contar tudo do que comece com a palavra “Muito”. Agora, se fizéssemos o seguinte:

=CONT.SE(B2:B7;”*Satisfeito”)

A contagem resultaria em 6. Porque? Mesmo a palavra “Insatisfeito” contém o texto “Satisfeito”, tornando sua contagem válida. É preciso atentar aos critérios pelo curinga para não trazer resultados inválidos.

O mesmo vale para a fórmula SOMA.SE e seus parâmetros. Facilita muito a vida por evitar o uso de fórmulas matriciais, muito mais complexas de se construir.

Bom proveito!