Excel – Invertendo texto usando fórmulas matriciais (sem VBA)

A dica foi dada originalmente pelo Johann Hackl no site TechNet, em inglês.

Antes de mais nada, a dica só funciona no Excel 2016. Passei um tempo frustrado e quase xingando o Excel 2013 quando percebi que para o truque funcionar, era preciso suporte à função CONCAT (é CONCAT mesmo, não CONCATENAR).

O mais bacana do post original é que ele não só dá e presente a função, mas explica como ela funciona passo a passo. Vou tentar fazer o mesmo por aqui.

A Fórmula

=SE(A2="";"";CONCAT(EXT.TEXTO(A2;1 + NÚM.CARACT(A2)-LIN(INDIRETO("1:" & NÚM.CARACT(A2)));1)))

Obviamente, o texto a ser invertido tem que estar na célula A2 (dã!).Também, como é uma fórmula matricial, você precisa pressionar Ctrl+Shift+Enter ao invés só só Enter.

Só isso fará o texto ser invertido.

A verdadeira mágica reside em duas frentes.  A primeiro é o uso de fórmulas matriciais. O segundo é o fato da função CONCAT aceitar ranges como argumento, algo que a função CONCATERNAR não faz. Junte isso tudo e você terá a funcionalidade, sem VBA!

Mais detalhes no post original (linkado acima)

Bom proveito!

Evento – Microsoft Excel: Aplicações e Produtividade, Quatro abordagens do uso da ferramenta

Fiquei sabendo da notícia hoje. Quatro gigantes da comunidade do brasileira de Excel se apresentarão num evento que ocorrerá no mês de Março em São Paulo, capital. Mais detalhes folder abaixo:

Microsoft Excel Aplicacoes Produtividade 2018

Ninguem mais ninguém menos do que Alessandro Trovato, Derlidio Siqueira, Fernando Fernandes e Luis Gustavo Serra estão presentes para fazer o que sabem melhor, falar de Excel e VBA!

Mais dados do evento:

Inscrições (valores e forma de pagamento): palestras-excel.eventbrite.com.br

Data: 31 de março de 2018, das 08:00 às 13:00.

Local: Espaço Maestro, R. Maestro Cardim, 1170 – Paraíso  – São Paulo / SP (próximo estação Paráiso do Metrô)

Vídeo – Tchau Selenium IDE, Katalon e Comunidade


É. tava demorando para que mais um projeto bacana sofresse do mal da falta de apoio da comunidade. Quem sabe não dá pra mudar isso?

Notícia no site do Selenium sobre a descontinuação ► https://seleniumhq.wordpress.com/2017/08/09/firefox-55-and-selenium-ide/
Katalon ► https://www.katalon.com/

Série Versus – Capítulo 3 ► https://www.youtube.com/watch?v=8QVxJAFH9to

Acesse também

BLOG ► https://www.tomasvasquez.com.br/blog/
FÓRUM ► https://www.tomasvasquez.com.br/forum/
CURSO ONLINE DE C# ► https://www.tomasvasquez.com.br/cursocsharp

Aqui também!

FACEBOOK ► https://www.facebook.com/tomasvaquezsites
TWITTER ► https://twitter.com/tomamais
GOOGLE+ ► https://plus.google.com/+TomasvasquezBr/

Roteiro, apresentação, edição, etc, etc ► eu mesmo 🙂

Technology, Education and whatever else

css.php

Tomás Vásquez – Blog is Stephen Fry proof thanks to caching by WP Super Cache