Arquivo da tag: Excel

Vídeo – Excel, atalhos bacanas para autocompletar e acelerar seu trabalho

Os atalhos estão aí para facilitar sua vida. Use e abuse deles!

Acesse também

BLOG ► https://www.tomasvasquez.com.br/blog/
FÓRUM ► https://www.tomasvasquez.com.br/forum/
CURSO ONLINE DE C# ► https://www.tomasvasquez.com.br/cursocsharp

Aqui também!

FACEBOOK ► https://www.facebook.com/tomasvaquezsites
TWITTER ► https://twitter.com/tomamais
GOOGLE+ ► https://plus.google.com/+TomasvasquezBr/

Roteiro, apresentação, edição, etc, etc ► eu mesmo 🙂

Recomendação – Aprenda Como Automatizar suas Tarefas no SAP com Excel VBA – Márcio Ribeiro


Sim, você entendeu. Isso é uma recomendação!

Para que acompanha o canal no YouTube (onde mais?), sabe que já trabalho em parceiria com o Márcio Ribeiro tem um bom tempo.  Dessa parceiria, surgiu a Série Versus, que dispensa apresentações.

O Márcio, além de um profissional mais do que qualificado na área de tecnologia, especialmente Excel e programaçào, também é um comunicador natural. Disso, é esperado que logo ele lançaria cursos que precederia a qualidade dos materiais que ele publica. E ele o fez!

Com você, o curso Aprenda Como Automatizar suas Tarefas no SAP com Excel VBA com Márcio Ribeiro!

Elogios são desnecessários. Tanto a página pessoal quanto seu canal do Youtube são recheados deles. O que realmente gostaria de compartilhar é que eu tive a oportunidade de avaliar o curso a convite do próprio Márcio.

O que posso dizer em um resumo é:

  • É completo
  • É focado
  • É claro e objetivo

Nem preciso dizer que esse curso reúne em um só material 2 tecnologias muito bem colocadas no mercado atualmente

  • Excel
  • VBA
  • SAP

Isso sem falar que as três trabalhando juntas culminam num efeito dos quais mais me familiarizo: Automação!

Se você é um profissional que tem em seu portifólio as qualificações mencionadas acima, dificilmente enfrentará problemas no mercado de trabalho.

Se interessou? Veja como saber mais de adquirir o curso clicando no link abaixo:

https://eduzz.com/curso/eXBR/.html?a=77684510

Ao colega Márcio Ribeiro, meus parabéns pelo trabalho e sucesso!

VBA – Carregando uma Imagem no UserForm

Está aí uma dúvida mais comum do que esperava. Carregar uma imagem num UserForm (ou planilha se preferir)? Siga os passos abaixo:

Abra o VBA (Alt+F11 com o Excel aberto)

Insira um UserForm:

Insira um UserForm
Insira um UserForm

Insira um controle de imagem no UserForm:

Insira um controle de imagem no UserForm
Insira um controle de imagem no UserForm

Arraste um botão de comando logo abaixo da Imagem:

Arraste um botão de comando logo abaixo da Imagem
Arraste um botão de comando logo abaixo da Imagem

Selecione o botão e na caixa de propriedades (clique em F4 se ela não estiver aparecendo), mude o texto do botão (Caption):

Selecione o botão e na caixa de propriedades mude o texto do botão
Selecione o botão e na caixa de propriedades mude o texto do botão

Clique duas vezes no botão para gerar o evento de Click:

Clique duas vezes no botão para gerar o evento de Click
Clique duas vezes no botão para gerar o evento de Click

E finalmente, o código:

Private Sub CommandButton1_Click()
    caminhoArquivo = Application.GetOpenFilename(FileFilter:="Image Files(*.jpg), *.jpg")
    Me.Image1.Picture = LoadPicture(caminhoArquivo)
End Sub

Execute o UserForm clicando em F5 e ao clicar no botão “Buscar Imagem”, você será apresentado a uma tela de escolha de arquivo como essa (já filtrando por arquivos de imagem. Reparei no filtro feito no código na linha 2):

Selecionando sua imagem
Selecionando sua imagem

Após selecionar a imagem, o resultado será parecido com este:

O resultado
O resultado

O mais atentos saberão que o código contém um bug. Se quiser saber a resposta, veja este link.

Arquivo: Carregar_Imagem_UserForm

Em vídeo!

Bom proveito!

Embelezando sua fórmula no Excel

A internet é um lugar lindo, principalmente para quem busca coisas lindas.

Viagens a parte, o que significa embelezar sua fórmula no Excel? Não, ela não ficará mais bonita. Ela nem vai mudar, mas, vai ficar muito mais fácil de você entendê-la. Vamos pegar esse post recente deste honorável blog como cobaia. A fórmula do artigo é esta:

=SE(A2="";"";CONCAT(EXT.TEXTO(A2;1 + NÚM.CARACT(A2)-LIN(INDIRETO("1:" & NÚM.CARACT(A2)));1)))

É até simples, mas, e se ela fosse apresentada de outra forma?

=SE(
    A2 = "";
    "";
    CONCAT(
        EXT.TEXTO(
            A2;
            1 +
            NÚM.CARACT(
                A2
            ) -
            LIN(
                INDIRETO(
                    "1:" &
                    NÚM.CARACT(
                        A2
                    )
                )
            );
            1
        )
    )
)

Não sei você, mas se você estiver procurando algum erro, ou querendo isolar um pedaço da fórmula, ou mesmo tentando entendê-la melhor, é muito mais simples se ela estiver formatada como acima. Quem faz esse mágica é o site Excel Formula Beautifier. Ele está disponível somente em inglês, mas deixa que você configure o separador de fórmulas para ser o “;” ou invés do “,” do Excel em inglês.

Veja como fica a fórmula deste artigo “embelezada”:

Tive que reduzir o zoom da página para caber
Tive que reduzir o zoom da página para caber

Muito além do Excel

Só de fazer o que faz e ser de graça, já vale a menção. Não bastasse tudo isso, ele converte fórmulas do Excel para expressões linguagens como o C#, Javascript ou Python. Veja o exemplo padrão do site convertido em C#:

Não é feitiçaria, é tecnologia!
Não é feitiçaria, é tecnologia!

Mais ainda, o código da página é aberta e está disponível no github!

Quer mais? A página do autor sobre o assunto lista uma série de projetos na mesma linha de avaliar fórmulas de modo a quebrá-la em partes para um melhor entendimento. Um que me chamou a atenção foi fórmula parser, escrito em C#, também disponível para download.  Veja como ele destrincha uma fórmula do Excel em partes:

Excel Formula Parsing, in C#
Excel Formula Parsing, in C#

Para terminar, lembro que neste vídeo que postei no canal lendo comentários, muitos me perguntaram como colaborar com a comunidade. Esse é um jeito.

Invente o seu!