ATENÇÃO NOVOS USUÁRIOS

Se registrou recentemente? Seu cadastro será avaliado e mendiante aprovação, a conta será ativada e você poderá usufruir do fórum. O tempo de avaliação gira em torno de 24 a 48 horas.

Esqueceu sua senha?

Você pode usar o mecanismo de lembrete neste link: Recuperar senha

Você receberá um link de reativação no email cadastrado.

Não recebeu o email? Lembre-se checar o Lixo Eletrônico.

Macro com PROCV

Ponto de encontro entre aqueles que precisam e fornecem soluções baseadas no Microsoft Excel e VBA. Precisa de uma solucão em VBA? É um consultor ou programador independente? Esse é o lugar!
Victor Ricardo
Acabou de chegar
Acabou de chegar
Mensagens: 2
Registrado em: Ter Jan 24, 2017 9:13 am

Macro com PROCV

Mensagem por Victor Ricardo » Ter Jan 31, 2017 8:49 am

Bom dia.

Estou com uma necessidade no meu trabalho e tenho dúvida:

Minha tarefa é atualizar uma planilha com dados PROCV que se modificam todos os dias.
Por exemplo, hoje (31/01) eu abri a planilha e troco os dados analisados no PROCV do dia 29/01 para 30/01, fazendo uma comparação do que mudou.

Preciso que isso se torne automático.

Agradeço desde já.

Att,
Editado pela última vez por Victor Ricardo em Sex Fev 03, 2017 9:37 am, em um total de 1 vez.



Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Avatar do usuário
Mikel Silveira Fraga
Jedi
Jedi
Mensagens: 1122
Registrado em: Sex Mai 27, 2011 3:27 pm
Localização: Betim - MG
Contato:

Re: [Ajuda] Macro com PROCV

Mensagem por Mikel Silveira Fraga » Qui Fev 02, 2017 9:11 am

Vitor, bom dia e seja bem vindo ao fórum.

Bem, como você não postou já tem pronto, vamos na base do teste e erro/acerto.

Se você tem que alterar todos os dias, provavelmente esta fazendo algo parecido com isso:

Código: Selecionar todos

=PROCV("31/01/2017";A1:C5;3;Falso)
Tente substituir a data pela formulá Hoje. O resultado seria algo assim:

Código: Selecionar todos

=PROCV(HOJE();A1:C5;3;Falso)
Dessa forma, você automatiza o processo de busca, bom base na data atual.

Veja se essa ideia atende sua necessidade.

Abraços e excelente semana.


Gostou da dica? Clique no JOIA no topo da mensagem.
Esclareceu suas dúvidas? Acrescente ao título do tópico a expressão: [RESOLVIDO].
Orientações sobre o fórum, acesse aqui.

Mikel Silveira Fraga
E-mail: mikel-sf@hotmail.com | Linked In

Victor Ricardo
Acabou de chegar
Acabou de chegar
Mensagens: 2
Registrado em: Ter Jan 24, 2017 9:13 am

Re: Macro com PROCV

Mensagem por Victor Ricardo » Sex Fev 03, 2017 7:20 am

Muito obrigado pela ajuda, Mikel!

Na realidade, minha PROCV não está baseada em uma data...
Ela segue no formato =PROCV('[dia 17.xlsx]Plan1'!E4;$E$4:$E$146;1;0) retirando um valor de uma célula da planilha do dia anterior e pesquisando na coluna (E4:E146) da planilha do dia de hoje, me retornando assim um valor para mostrar o número de pedido faturado e seu respectivo cliente.

Te mandei um e-mail para que pudesse dar uma olhada na planilha.

Agradeço novamente!!



Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Responder